summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-07-18 22:25:56 +0200
committerQt by Nokia <qt-info@nokia.com>2012-07-24 08:44:27 +0200
commit45cb8be4f9ab2b5b823dda104376b159c9123163 (patch)
tree833e53808d216375ca10a84a384775f897f6c49f /tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt
parent4eb64827515f7d72e3c5cf259c4bc2c1cc0d58bf (diff)
Add tests of the various testlib definition possibilities.
The behavior of QTEST_MAIN depends on whether QT_GUI_LIB or QT_WIDGETS_LIB is defined. It could create a QGuiApplication or QApplication which could cause linking issues if the corresponding library is not linked to. The failure cases are also tested. Change-Id: I61ed0bc760564ef42ce1dbd86c83c06348c860ff Reviewed-by: Rohan McGovern <rohan.mcgovern@nokia.com>
Diffstat (limited to 'tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt b/tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt
new file mode 100644
index 0000000000..cc68be18b8
--- /dev/null
+++ b/tests/auto/cmake/test_testlib_definitions/core_only/CMakeLists.txt
@@ -0,0 +1,4 @@
+
+project(core_only)
+
+test_testlib_project(Core)