summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_use_modules_function/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-05-28 21:20:55 +0200
committerThiago Macieira <thiago.macieira@intel.com>2015-05-29 00:08:41 +0000
commite3983c87280ade48b243d9c60bed639713851be9 (patch)
treec370ee7f6fb9ffaad46501e89b528ed4a0558991 /tests/auto/cmake/test_use_modules_function/CMakeLists.txt
parent95b6c4fed6521aa2212cab67cb8a6e5553e86117 (diff)
Revert some changes in light of GCC 4 -fPIE reversalv5.4.2
The -fPIE option is now accepted when using GCC 4, which means it is available for backward compatibility for clients using CMake 2.8.11 or older which makes use of the POSITION_INDEPENDENT_CODE feature. Conditionally use that feature for old versions of cmake with GCC 4. Restore the tests for those versions, and clarify the situation in the ChangeLog. Change-Id: I5a06b155dda7db559d86841a2b34fd8ed95acbd0 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/cmake/test_use_modules_function/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_use_modules_function/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/auto/cmake/test_use_modules_function/CMakeLists.txt b/tests/auto/cmake/test_use_modules_function/CMakeLists.txt
index be05c75054..bfcdd9d1d7 100644
--- a/tests/auto/cmake/test_use_modules_function/CMakeLists.txt
+++ b/tests/auto/cmake/test_use_modules_function/CMakeLists.txt
@@ -12,7 +12,5 @@ add_executable(three three.cpp)
find_package(Qt5Core)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-
qt5_use_modules(two Test)
qt5_use_modules(three Gui Test)