summaryrefslogtreecommitdiffstats
path: root/tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas.buhr@qt.io>2020-10-09 00:02:00 +0200
committerAndreas Buhr <andreas.buhr@qt.io>2020-11-09 16:01:33 +0100
commit223e409efbf29f7c06bec7a403403c9689f42b3e (patch)
tree005c43d0ac9d33a74af85e5e3e9c0277b19dadd9 /tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt
parent3553f8119b5cd8c04c7208c519bb08245a44720e (diff)
Automatically generate unit tests for QtConcurrent
There are many different ways to to call map and filter functions in QtConcurrent. This patch adds a python script to generate all possible combinations. Change-Id: I61ed1758601e219c5852e8cc939c5feebb23d2f6 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jarek Kobus <jaroslaw.kobus@qt.io>
Diffstat (limited to 'tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt')
-rw-r--r--tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt b/tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt
new file mode 100644
index 0000000000..c2a11627ca
--- /dev/null
+++ b/tests/auto/concurrent/qtconcurrentfiltermapgenerated/CMakeLists.txt
@@ -0,0 +1,12 @@
+#####################################################################
+## tst_qtconcurrentfiltermapgenerated Test:
+#####################################################################
+
+qt_internal_add_test(tst_qtconcurrentfiltermapgenerated
+ SOURCES
+ tst_qtconcurrentfiltermapgenerated.cpp
+ tst_qtconcurrentfiltermapgenerated.h
+ tst_qtconcurrent_selected_tests.cpp
+ PUBLIC_LIBRARIES
+ Qt::Concurrent
+)