summaryrefslogtreecommitdiffstats
path: root/tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Fanaskov <vitaly.fanaskov@qt.io>2020-03-11 18:07:03 +0100
committerVitaly Fanaskov <vitaly.fanaskov@qt.io>2020-03-29 20:44:32 +0100
commit5a0d4f3313157d2fe48e9d159968bed6883eb5f8 (patch)
treed7366ac16fdbe83ff4e8006577f9987404ae2742 /tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt
parentd975ad4ed728553b765c61f38c1e0df899187cf5 (diff)
QtConcurrent: add fluent interface to configure a task before run
Task-number: QTBUG-82950 Change-Id: I449da938b6b501a7646b3425edde5c880d6ca87e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Mikhail Svetkin <mikhail.svetkin@gmail.com>
Diffstat (limited to 'tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt')
-rw-r--r--tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt b/tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt
new file mode 100644
index 0000000000..d55a0536cf
--- /dev/null
+++ b/tests/auto/concurrent/qtconcurrenttask/CMakeLists.txt
@@ -0,0 +1,6 @@
+add_qt_test(tst_qtconcurrenttask
+ SOURCES
+ tst_qtconcurrenttask.cpp
+ PUBLIC_LIBRARIES
+ Qt::Concurrent
+)