summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qflags/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2022-02-26 02:23:40 +0100
committerMarc Mutz <marc.mutz@qt.io>2022-03-08 11:16:19 +0100
commitb142d2ad73c6fc596c96b459f70525e685e50fc0 (patch)
tree109d65bf3e0d2ac4cfeef3c180c7a94cd45f5905 /tests/auto/corelib/global/qflags/CMakeLists.txt
parent0335755e52a4d5b429793123331f408a6609f0af (diff)
tst_qflags: test w/and w/o QT_TYPESAFE_FLAGS
Also contains some fixes which fix the Windows build, amending e1b8257deeff67025d75b4b3c27b571b418eefee. Pick-to: 6.3 Fixes: QTBUG-101294 Fixes: QTBUG-101304 Change-Id: I779f50fc705ed32f0314daf28b39b477a7fe925d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/corelib/global/qflags/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qflags/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/auto/corelib/global/qflags/CMakeLists.txt b/tests/auto/corelib/global/qflags/CMakeLists.txt
index 998834d619..8ba02d93b4 100644
--- a/tests/auto/corelib/global/qflags/CMakeLists.txt
+++ b/tests/auto/corelib/global/qflags/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from qflags.pro.
-
#####################################################################
## tst_qflags Test:
#####################################################################
@@ -9,5 +7,9 @@ qt_internal_add_test(tst_qflags
tst_qflags.cpp
)
-## Scopes:
-#####################################################################
+qt_internal_add_test(tst_qflags_non_typesafe
+ SOURCES
+ tst_qflags.cpp
+ DEFINES
+ QFLAGS_TEST_NO_TYPESAFE_FLAGS
+)