summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/CMakeLists.txt
diff options
context:
space:
mode:
authorTatiana Borisova <tatiana.borisova@qt.io>2021-12-15 10:39:45 +0200
committerTatiana Borisova <tatiana.borisova@qt.io>2021-12-30 15:38:14 +0000
commit72ba7cb1865081bbc8fefd77c9fe616157358410 (patch)
tree4038be6efe4c68cb8a225215ac9cc9881fe0ebc6 /tests/auto/corelib/io/CMakeLists.txt
parentc90bb659261ded691baad5be557c088fb787becf (diff)
Exclude filesystem autotests for INTEGRITY
- There is no mounted partition, where we can create/delete files at runtime. Tests should be excluded for now. Pick-to: 6.2 6.3 Change-Id: I1c4db13d35da7d570c4bf787299d829e08951195 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/corelib/io/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/CMakeLists.txt b/tests/auto/corelib/io/CMakeLists.txt
index 040e3dcf16..f4cfc16f06 100644
--- a/tests/auto/corelib/io/CMakeLists.txt
+++ b/tests/auto/corelib/io/CMakeLists.txt
@@ -1,4 +1,8 @@
# Generated from io.pro.
+# There is no mounted filesystem for IO testing on INTEGRITY yet.
+if(INTEGRITY)
+ return()
+endif()
if(QT_FEATURE_private_tests)
add_subdirectory(qabstractfileengine)