summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qdebug/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2022-04-26 10:56:54 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2022-04-27 00:16:26 +0200
commitaa0a53fc19be10b8b1d191415bda82af259a8b23 (patch)
tree1fd2a8587a056427368ce183578a2f667cbe8bd3 /tests/auto/corelib/io/qdebug/CMakeLists.txt
parentc164b75c175394000b17486c853be95e9e6d5752 (diff)
Don't declare type 'id' in the global namespace in a public header
It's not necessary, and it breaks the qttools build (where we have a global variable named 'id'), and thus will most certainly build a lot of existing user code. Amends e47c22480fe84c100019cd92d0296f0dd2a7f3f1. Change-Id: I97a91c2cb23fdae65143cf14c81570cf88d529d5 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qdebug/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qdebug/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qdebug/CMakeLists.txt b/tests/auto/corelib/io/qdebug/CMakeLists.txt
index 39b92b9d2f..067e3be04b 100644
--- a/tests/auto/corelib/io/qdebug/CMakeLists.txt
+++ b/tests/auto/corelib/io/qdebug/CMakeLists.txt
@@ -10,3 +10,7 @@ qt_internal_add_test(tst_qdebug
PUBLIC_LIBRARIES
Qt::Concurrent
)
+
+if (APPLE)
+ target_compile_options(tst_qdebug PRIVATE -x objective-c++)
+endif()