summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qlockfile/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Welbourne <edward.welbourne@qt.io>2021-09-08 14:04:59 +0200
committerEdward Welbourne <edward.welbourne@qt.io>2021-09-17 12:57:25 +0200
commitcbd33cb55757122e2c02356285c335af969dcd43 (patch)
treed57e3098209fa16ad97bff1f315eface2bacc708 /tests/auto/corelib/io/qlockfile/CMakeLists.txt
parentfb3549fc47b19de2956cd2dda07ef67ec529cf3e (diff)
Add missing dependencies of tests on their helper programs
This ensures that a command such as $ ninja tst_qlocale && ninja tst_qlocale_check will automagically build the syslocaleapp program that the test runs from a subtest. Similar for testlib's selftests and tst_QProcess. As a drive-by, pruned some legacy comments from when CMakeLists.txt files were generated from .pro files. Change-Id: I67691a8175aaef124d4104cf1898193993408bdf Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com> Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qlockfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qlockfile/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/auto/corelib/io/qlockfile/CMakeLists.txt b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
index 828aea049e..456ee88bb0 100644
--- a/tests/auto/corelib/io/qlockfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
@@ -1,5 +1,3 @@
-# Generated from qlockfile.pro.
-
#####################################################################
## tst_qlockfile Test:
#####################################################################
@@ -20,3 +18,7 @@ qt_internal_extend_target(tst_qlockfile CONDITION WIN32
advapi32
)
add_subdirectory(qlockfiletesthelper)
+
+if(QT_FEATURE_process AND NOT ANDROID)
+ add_dependencies(tst_qlockfile qlockfile_test_helper)
+endif()