summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-04-28 11:30:46 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2020-05-04 19:21:15 +0200
commited6fbeffb233e4028f77d8a9edae1188424c0ab8 (patch)
tree0f4dcd482f83dca5a8c54a3597073c603c60da6f /tests/auto/corelib/io/qprocess/test/CMakeLists.txt
parent112c285fcc065d07734b30ba49a62ead3be3d2c4 (diff)
Port more tests from qtbase/tests/auto/corelib/io/ to CMake
Change-Id: I56427e3e1908047a0674c8c80c24eeda80e947c2 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qprocess/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/test/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qprocess/test/CMakeLists.txt b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
new file mode 100644
index 0000000000..0541b4258a
--- /dev/null
+++ b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from test.pro.
+
+#####################################################################
+## tst_qprocess Test:
+#####################################################################
+
+qt_add_test(tst_qprocess
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
+ SOURCES
+ ../../../../../shared/emulationdetector.h
+ ../tst_qprocess.cpp
+ INCLUDE_DIRECTORIES
+ ../../../../../shared
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Network
+)
+
+#### Keys ignored in scope 1:.:.:test.pro:<TRUE>:
+# TEST_HELPER_INSTALLS = "../testProcessSpacesArgs/nospace" "../testProcessSpacesArgs/one space" "../testProcessSpacesArgs/two space s" "../test Space In Name/testSpaceInName"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:test.pro:WIN32:
+# TESTDATA = "../testBatFiles/*"
+
+#### Keys ignored in scope 5:.:..:../qprocess.pri:NOT TARGET Qt::Widgets:
+# SUBPROGRAMS = "-testGuiProcess"