summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amir.abdol@qt.io>2023-03-09 15:38:58 +0100
committerAmir Masoud Abdol <amir.abdol@qt.io>2023-03-14 17:28:43 +0100
commite51273427814b05affa4dd642d2ec77be83969c1 (patch)
tree4d8d67f33be9f20f86f878b783f9d399a1b57183 /tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt
parent3e1108aa7fbc69244254e128b97eac528e35d03d (diff)
Use qt_internal_add_executable in auto tests
When possible, I replaced add_executable with qt_internal_add_executable. Pick-to: 6.5 Task-number: QTBUG-109394 Change-Id: I643d2e27f0d880fe9b6cec7af790e4c99227fb0c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt b/tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt
index ba8a92ab30..256253e707 100644
--- a/tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocess/testProcessHang/CMakeLists.txt
@@ -5,4 +5,8 @@
## testProcessHang Binary:
#####################################################################
-add_executable(testProcessHang main.cpp)
+qt_internal_add_executable(testProcessHang
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ SOURCES
+ main.cpp
+)