summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qresourceengine/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-08-23 12:45:42 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-08-24 23:27:30 +0200
commitd9f8b689637aa4559ee57dc80aef0d4325d14e0c (patch)
tree870887b9ef8d822fecdd254535a5080b60636a17 /tests/auto/corelib/io/qresourceengine/CMakeLists.txt
parent869410480914cfa6429950e1fc10fa837eae3656 (diff)
Revive tst_qresourceengine
This test was not ported to CMake yet. Pick-to: 6.2 Fixes: QTBUG-88601 Change-Id: Ied3b1a0e2ddfbcf003cb0d8d01d5f64cb83cf4e7 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qresourceengine/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qresourceengine/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qresourceengine/CMakeLists.txt b/tests/auto/corelib/io/qresourceengine/CMakeLists.txt
new file mode 100644
index 0000000000..7152d988c9
--- /dev/null
+++ b/tests/auto/corelib/io/qresourceengine/CMakeLists.txt
@@ -0,0 +1,44 @@
+#####################################################################
+## tst_qresourceengine Test:
+#####################################################################
+
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qresourceengine LANGUAGES C CXX ASM)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
+# Collect test data
+set(test_data "parentdir.txt")
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testqrc/*)
+list(APPEND test_data ${test_data_glob})
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ *.rcc)
+list(APPEND test_data ${test_data_glob})
+
+qt_internal_add_test(tst_qresourceengine
+ SOURCES
+ tst_qresourceengine.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ moctestplugin
+ TESTDATA ${test_data}
+)
+
+qt_add_resources(additional_sources testqrc/test.qrc)
+target_sources(tst_qresourceengine PRIVATE ${additional_sources})
+
+if(ANDROID AND NOT ANDROID_EMBEDDED)
+ qt_add_resources(additional_sources android_testdata.qrc)
+ target_sources(tst_qresourceengine PRIVATE ${additional_sources})
+endif()
+
+qt_add_binary_resources(tst_qresourceengine_runtime_resource "testqrc/test.qrc"
+ DESTINATION "${CMAKE_CURRENT_BINARY_DIR}/runtime_resource.rcc"
+ OPTIONS -root "/runtime_resource/" -binary)
+add_dependencies(tst_qresourceengine tst_qresourceengine_runtime_resource)
+
+add_subdirectory(staticplugin)