summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-08-23 12:45:42 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-08-24 23:27:30 +0200
commitd9f8b689637aa4559ee57dc80aef0d4325d14e0c (patch)
tree870887b9ef8d822fecdd254535a5080b60636a17 /tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt
parent869410480914cfa6429950e1fc10fa837eae3656 (diff)
Revive tst_qresourceengine
This test was not ported to CMake yet. Pick-to: 6.2 Fixes: QTBUG-88601 Change-Id: Ied3b1a0e2ddfbcf003cb0d8d01d5f64cb83cf4e7 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt b/tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt
new file mode 100644
index 0000000000..5e2e374310
--- /dev/null
+++ b/tests/auto/corelib/io/qresourceengine/staticplugin/CMakeLists.txt
@@ -0,0 +1,22 @@
+#####################################################################
+## moctestplugin Generic Library:
+#####################################################################
+
+qt_internal_add_cmake_library(moctestplugin
+ STATIC
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Core
+ DEFINES
+ QT_STATICPLUGIN
+)
+
+qt_internal_add_resource(moctestplugin "qmake_plugin_resource"
+ PREFIX
+ "/staticplugin"
+ FILES
+ "main.cpp"
+)
+
+qt_autogen_tools_initial_setup(moctestplugin)