summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurl/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrei Golubev <andrei.golubev@qt.io>2021-04-26 14:59:16 +0200
committerAndrei Golubev <andrei.golubev@qt.io>2021-04-27 14:12:34 +0200
commitc3d16e21265ebacca1018b31490b63f8738333a5 (patch)
treec832ea2d8eb73ead41f9d23ee2961e671fd4f02f /tests/auto/corelib/io/qurl/CMakeLists.txt
parente6f7202e34f407a316d1c96a6b3a55f24dd068d8 (diff)
Skip tst_QUrl::testThreading() under QEMU
It usually fails the test with "corrupted size vs. prev_size" message coming from malloc() or some other memory allocation routine (which signals about memory corruption probably) Task-number: QTBUG-93176 Change-Id: I5e34971267c52c63cda2489bef5b09bed739f532 Reviewed-by: Lars Knoll <lars.knoll@qt.io> (cherry picked from commit 6d52d86b999088ec07e58c14197bddda043ef0aa) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/auto/corelib/io/qurl/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurl/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qurl/CMakeLists.txt b/tests/auto/corelib/io/qurl/CMakeLists.txt
index ce386c142c..b5a2ec0331 100644
--- a/tests/auto/corelib/io/qurl/CMakeLists.txt
+++ b/tests/auto/corelib/io/qurl/CMakeLists.txt
@@ -9,6 +9,7 @@ qt_internal_add_test(tst_qurl
tst_qurl.cpp
PUBLIC_LIBRARIES
Qt::Concurrent
+ Qt::TestPrivate
)
## Scopes: