summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-07-16 14:22:37 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-07-18 08:05:58 +0000
commit3212f1b8662b5e5483a0185c22820e2d14593aba (patch)
treecd4fade474dd814609343a2e84c0c882db05d00b /tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt
parent341ccc3b590d0a06157f29ce9237bc111e8cebf8 (diff)
Add special case handling for corelib mimetypes resources
We have to treat the resources from mimetypes in corelibs specially as they are reused for two test cases. Since we no longer use the qrc files, we have wrapped the relevant code in a function that can be called for every target that depends on it. This change also corrects formatting for the generate CMake code regarding resource commands. Change-Id: I50a05c81151d75aefc9ca165f5ffeb9f5cd77162 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt b/tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt
new file mode 100644
index 0000000000..6661952a68
--- /dev/null
+++ b/tests/auto/corelib/mimetypes/qmimedatabase/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Generated from qmimedatabase.pro.
+
+
+if(TARGET Qt::Concurrent)
+ add_subdirectory(qmimedatabase-xml)
+
+ if(UNIX AND NOT APPLE AND NOT QNX)
+ add_subdirectory(qmimedatabase-cache)
+ endif()
+endif()