summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 18:01:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 09:38:35 +0200
commite9a328bc0e56b429a370b13c8e0b4790916cebde (patch)
tree059f3b089a8557cb4c45e3dc059b58e020e34dcb /tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt
parent5417f1e40cb647c05bffad21493feacac45f193e (diff)
CMake: Regenerate tests with new qt_ prefixed APIs
Use pro2cmake with '--api-version 2' to force regenerate projects to use the new prefixed qt_foo APIs. Change-Id: I055c4837860319e93aaa6b09d646dda4fc2a4069 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt b/tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt
index 5208a70c9d..c8a320d2cf 100644
--- a/tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qpluginloader/almostplugin/CMakeLists.txt
@@ -4,7 +4,7 @@
## almostplugin Generic Library:
#####################################################################
-add_cmake_library(almostplugin
+qt_add_cmake_library(almostplugin
MODULE
INSTALL_DIRECTORY "${INSTALL_TESTSDIR}/tst_qpluginloader/bin"
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../bin"
@@ -25,7 +25,7 @@ add_cmake_library(almostplugin
qt_autogen_tools_initial_setup(almostplugin)
# special case begin
# We want the opposite of this
-#extend_target(almostplugin CONDITION GCC
+#qt_extend_target(almostplugin CONDITION GCC
# LINK_OPTIONS
# "--Wl,--no-undefined"
#)