summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-10-23 14:45:20 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-10-28 09:20:37 +0000
commit69fb4ae343777af9078e5128ec41cfb3cea2cd76 (patch)
tree7d15b4dde18289f583dc195f121556b04dd85e55 /tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
parent080f9ad160ef7422b2bab884c7ccc950d35b3a0a (diff)
Distinguish between qt_plugin and regular plugins
If we do not encounter the load(qt_plugin) statement in the .pro file but we do see the entry CONFIG+=plugin, treat the target as a regular CMake library instead of treating it as a qt_plugin by default. Change-Id: I67ad5c865a1a5ab691a6b0d86c2db4b686aa04dd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt b/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
index 3eb62d511a..5389790fba 100644
--- a/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
+++ b/tests/auto/corelib/plugin/qpluginloader/theplugin/CMakeLists.txt
@@ -1,10 +1,11 @@
# Generated from theplugin.pro.
#####################################################################
-## theplugin Plugin:
+## theplugin Generic Library:
#####################################################################
-add_qt_plugin(theplugin
+add_cmake_library(theplugin
+ MODULE
INSTALL_DIRECTORY "${INSTALL_TESTSDIR}/tst_qpluginloader/bin"
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../bin"
SOURCES
@@ -26,3 +27,5 @@ add_qt_plugin(theplugin
#### Keys ignored in scope 6:.:..:../winrt.pri:else:
# DESTDIR = "../release/bin"
+
+qt_autogen_tools_initial_setup(theplugin)