summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-22 10:16:58 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 16:59:06 +0200
commit403213240c7b2dc09378e1cb8c147131e368f90c (patch)
treeff86910332629fe5e2fab59a30fb863a5febb366 /tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
parente0c62a48b8a826a46a143e57e94b2a0ea73c7cae (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Clean up some stale .prev files that are not needed anymore. Clean up some project files that are not used anymore. Task-number: QTBUG-86815 Change-Id: I9947da921f98686023c6bb053dfcc101851276b5 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
index 4471335770..61d594900f 100644
--- a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
@@ -12,7 +12,7 @@ list(APPEND test_data "../tst_qtextstream.cpp")
list(APPEND test_data "../resources")
list(APPEND test_data "../BLACKLIST")
-qt_add_test(tst_qtextstream
+qt_internal_add_test(tst_qtextstream
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../../../../../shared/emulationdetector.h
@@ -36,7 +36,7 @@ set(qtextstream_resource_files
"resources/little_endian/"
)
-qt_add_resource(tst_qtextstream "qtextstream"
+qt_internal_add_resource(tst_qtextstream "qtextstream"
PREFIX
"/tst_textstream/"
BASE
@@ -49,7 +49,7 @@ qt_add_resource(tst_qtextstream "qtextstream"
## Scopes:
#####################################################################
-qt_extend_target(tst_qtextstream CONDITION builtin_testdata
+qt_internal_extend_target(tst_qtextstream CONDITION builtin_testdata
DEFINES
BUILTIN_TESTDATA
)