summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-02-10 20:21:30 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-02-11 21:54:44 +0100
commit815bc61626825ec5572d642e6baaec9158d81044 (patch)
tree372bf9774d10aaa09238dd43866ded06cb43fa14 /tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
parentfdf5d11ff6f3f5034d7d7f7664f4cc76deb26ef5 (diff)
Cleanup tests that add test data to resources explicitly
Remove Integrity and Android specific code that explicitly adds test data to the resource files. qt_internal_add_test functions implicitly adds test data to resources for Android and Integrity platforms by default. Change-Id: Ia1d58755b47442e1953462e38606f70fec262368 Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt24
1 files changed, 1 insertions, 23 deletions
diff --git a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
index cb48aed16c..c0b9752fc5 100644
--- a/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/qtextstream/test/CMakeLists.txt
@@ -36,28 +36,6 @@ qt_internal_add_resource(tst_qtextstream "qtextstream"
${qtextstream_resource_files}
)
-if(INTEGRITY)
-set(qtextstream_resource_files_integrity
- "../rfc3261.txt"
- "../task113817.txt"
- "../tst_qtextstream.cpp"
-)
-
-qt_internal_add_resource(tst_qtextstream "qtextstream_integrity"
- PREFIX
- "/"
- FILES
- ${qtextstream_resource_files_integrity}
-)
-endif()
-
-## Scopes:
-
-qt_internal_extend_target(tst_qtextstream CONDITION builtin_testdata OR INTEGRITY
- DEFINES
- BUILTIN_TESTDATA
-)
-
if(QT_FEATURE_process)
- add_dependencies(tst_qtextstream stdinProcess readAllStdinProcess readLineStdinProcess)
+ add_dependencies(tst_qtextstream stdinProcess readAllStdinProcess readLineStdinProcess)
endif()