summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2023-03-31 13:38:07 +0200
committerMarc Mutz <marc.mutz@qt.io>2023-04-26 12:01:05 +0200
commitb85a9d0ee16e3bdc817eb1e8a8f85026e631b401 (patch)
treebc0b8e05d2d2aee8bd2a96fdccbf7424ca304f2e /tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt
parentcd800da526aaf0369f9cf4780db065026ddad7dd (diff)
Move QZipReader/Writer from QtGui to QtCore
These classes depend only on Core, not Gui. This allows dropping the dependency of tst_qxmlstream and tst_qzip on QtGui, and prevents a tst_qxmlstream FTBFS when building with QT_NO_TEXTODFWRITER. Symbols move from QtGui to QtCore, but the classes are private API, so not under BC constraints. The classes are not used outside qtbase, so no other in-tree users need porting. Task-number: QTBUG-3897 Change-Id: Ifa148f43ec139d7f9ac1f3893e2fcf4640e3c60c Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt b/tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt
index 3304097d4b..e7dd05944e 100644
--- a/tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt
+++ b/tests/auto/corelib/serialization/qxmlstream/CMakeLists.txt
@@ -15,6 +15,6 @@ qt_internal_add_test(tst_qxmlstream
tst_qxmlstream.cpp
LIBRARIES
Qt::Network
- Qt::GuiPrivate
+ Qt::CorePrivate
TESTDATA ${test_data}
)