summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qbytearray/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-04-24 16:37:42 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2020-04-27 14:34:51 +0200
commit7e1dacc27a8a9b10c51d42f816083e77e7ad0690 (patch)
tree59450243c316e8e4238b142206fb074d999bdef6 /tests/auto/corelib/text/qbytearray/CMakeLists.txt
parentceaf23b361a44759892def4270b243fac56db8ba (diff)
Port qtbase/tests/auto/corelib/text tests to CMake
Task-number: QTBUG-78220 Change-Id: I497da6ed489854bdee5a1ead9a3f34118c78d001 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/text/qbytearray/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qbytearray/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/auto/corelib/text/qbytearray/CMakeLists.txt b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
new file mode 100644
index 0000000000..f2fd281f90
--- /dev/null
+++ b/tests/auto/corelib/text/qbytearray/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from qbytearray.pro.
+
+#####################################################################
+## tst_qbytearray Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "rfc3252.txt")
+
+qt_add_test(tst_qbytearray
+ SOURCES
+ tst_qbytearray.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_qbytearray CONDITION APPLE
+ SOURCES
+ tst_qbytearray_mac.mm
+ PUBLIC_LIBRARIES
+ ${FWFoundation}
+)
+
+if(ANDROID AND NOT ANDROID_EMBEDDED)
+ # Resources:
+ set(android_testdata_resource_files
+ "rfc3252.txt"
+ )
+
+ qt_add_resource(tst_qbytearray "android_testdata"
+ PREFIX
+ "/"
+ FILES
+ ${android_testdata_resource_files}
+ )
+endif()