summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-07-06 13:08:50 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2020-07-08 08:45:14 +0200
commita55e938fb41dfb781cdef6a4e24961a272d2dbab (patch)
tree93e5a540bf7e38768eb2d497499ccc0f87e7f548 /tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt
parentf96244f614894b19e5964925db963aeb56e16bdd (diff)
Add tst_QByteArrayApiSymmetry test
Created tst_QByteArrayApiSymmetry test for the common APIs of QByteArray and QByteArrayView. Moved the tests for startsWith(), endsWith(), indexOf(), lastIndexOf(), compare(), from tst_QByteArray to tst_QByteArrayApiSymmetry and adapted them to check different QByteArray/QByteArrayView combinations. Added tests for first(), last(), sliced(), chopped(), chop(), truncate(), count(), contains() (test inputs are taken from corresponding tst_QStringApiSymmetry tests). Task-number: QTBUG-84321 Change-Id: I4e712b1692e3c1271d51ddcda6c9eb8bb01e11d4 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt b/tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt
new file mode 100644
index 0000000000..bc49aabc5b
--- /dev/null
+++ b/tests/auto/corelib/text/qbytearrayapisymmetry/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Generated from qbytearrayapisymmetry.pro.
+
+#####################################################################
+## tst_qbytearrayapisymmetry Test:
+#####################################################################
+
+qt_add_test(tst_qbytearrayapisymmetry
+ SOURCES
+ tst_qbytearrayapisymmetry.cpp
+)