summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/text/qstring/CMakeLists.txt
diff options
context:
space:
mode:
authorAhmad Samir <a.samirh78@gmail.com>2023-01-24 13:42:28 +0200
committerAhmad Samir <a.samirh78@gmail.com>2023-04-29 18:15:23 +0200
commit7564583d362cc456bd6b17878ac25f6d93d113a8 (patch)
treeb7f3e622aea15d2cd3c0470ea9722c60dc372c8f /tests/auto/corelib/text/qstring/CMakeLists.txt
parent37dc52d4f24c216811cf14ceb8aeaa13766b249d (diff)
QString: add a tst_QString variant with QT_NO_CAST_FROM_ASCII
Now the tst_qstring is compiled three times: - with QT_NO_CAST_FROM_ASCII defined - with QT_RESTRICTED_CAST_FROM_ASCII defined - with neither of the above defined so as to cover more code paths. Pick-to: 6.5 Task-number: QTBUG-109228 Change-Id: I65eca0f6f6aea66fed6eeda1eb77a50a97210807 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/corelib/text/qstring/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/text/qstring/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/corelib/text/qstring/CMakeLists.txt b/tests/auto/corelib/text/qstring/CMakeLists.txt
index d3db36e813..d0c233acd3 100644
--- a/tests/auto/corelib/text/qstring/CMakeLists.txt
+++ b/tests/auto/corelib/text/qstring/CMakeLists.txt
@@ -13,7 +13,7 @@ if(WASM)
list(APPEND tst_qstring_extra_sources tst_qstring_wasm.cpp)
endif()
-foreach(test tst_qstring tst_qstring_restricted_ascii)
+foreach(test tst_qstring tst_qstring_restricted_ascii tst_qstring_no_cast_from_ascii)
qt_internal_add_test(${test}
SOURCES
tst_qstring.cpp
@@ -31,3 +31,9 @@ qt_internal_extend_target(tst_qstring_restricted_ascii
QT_RESTRICTED_CAST_FROM_ASCII
tst_QString=tst_QString_restricted_ascii
)
+
+qt_internal_extend_target(tst_qstring_no_cast_from_ascii
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ tst_QString=tst_QString_no_cast_from_ascii
+)