summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Wierciński <piotr.wiercinski@qt.io>2023-09-07 15:13:01 +0200
committerPiotr Wierciński <piotr.wiercinski@qt.io>2023-09-14 11:58:48 +0200
commit9468ef2cfb9a3ebe14382427b67aaafbbad7d847 (patch)
tree104ee997bc2fb0fddac59180e3a293b6e9ef9b5c /tests/auto/corelib/thread/CMakeLists.txt
parent5ac97a38e840da4dad0d5b0e1acbf2ecb46ecf74 (diff)
CI: Enable some tests under corelib/thread for Wasm platform
This is part of our testing effort where we try enabling more tests for Web Assembly platform on CI. Not all tests work out of box, so some of them will require followup work. This commmit also introduces a new mechanism of automatically renaming files when they are added many times with the same filename to single translation unit. Change-Id: I620536494ea83aeb9b294c4a35ef72b51e85a38b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'tests/auto/corelib/thread/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/corelib/thread/CMakeLists.txt b/tests/auto/corelib/thread/CMakeLists.txt
index c1c00fe84d..64c0f47ca5 100644
--- a/tests/auto/corelib/thread/CMakeLists.txt
+++ b/tests/auto/corelib/thread/CMakeLists.txt
@@ -1,6 +1,19 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
+if(WASM) # not all tests currently work in WebAssembly
+ add_subdirectory(qatomicint)
+ add_subdirectory(qatomicinteger)
+ add_subdirectory(qatomicpointer)
+ add_subdirectory(qfuturesynchronizer)
+ add_subdirectory(qfuturewatcher)
+ add_subdirectory(qmutexlocker)
+ add_subdirectory(qreadlocker)
+ add_subdirectory(qresultstore)
+ add_subdirectory(qwritelocker)
+ return()
+endif()
+
if(QT_FEATURE_thread)
add_subdirectory(qatomicint)
add_subdirectory(qatomicinteger)