summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-03 13:24:51 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-04 06:27:19 +0000
commita98f64af91f8e96d2efe2b57d64f9fc41e2006b4 (patch)
treebd596327bdac61db23acd6e63ebf9143e56556dd /tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt
parente1beabc3b87ee202fa90af906be0cfeb2ffc2464 (diff)
cmake: add more tests in corelib/thread
This fixes the qatomicinteger magic by making $$basename work for one particular case. qthreadstorage still needs investigation. Task-number: QTBUG-78221 Change-Id: I7bb38f6ca24273bcf0443ab25685c8e815814c3c Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt b/tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt
new file mode 100644
index 0000000000..561274da9d
--- /dev/null
+++ b/tests/auto/corelib/thread/qatomicinteger/uint/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Generated from uint.pro.
+
+#####################################################################
+## tst_qatomicinteger_uint Test:
+#####################################################################
+
+add_qt_test(tst_qatomicinteger_uint
+ SOURCES
+ ../tst_qatomicinteger.cpp
+ DEFINES
+ QATOMIC_TEST_TYPE=uint
+ tst_QAtomicIntegerXX=tst_QAtomicInteger_uint
+)