summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/time/qdate/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2023-09-13 17:21:34 +0200
committerIvan Solovev <ivan.solovev@qt.io>2023-11-13 16:35:54 +0100
commitbfb237d19a5319bfa020ad0cefaff72e8d94a9be (patch)
tree60c7d18596c120c71680960473201694be1a28b3 /tests/auto/corelib/time/qdate/CMakeLists.txt
parente4bde15e149cf449911c9b871acfe8fafd4ac712 (diff)
TestLib: provide helper functions to test relational operators
The patch provides two sets of functions: * functions to perform compile-time check for all cv-ref combinations * functions that actually verify the comparison results for all cv-ref combinations. For now it does not test operator<=>(), even if compiled with C++20, because Qt types do not yet implement it. The patch uses the new helper functions to improve testing of date and time classes, because they already provide a full set of relational operators. Change-Id: I8bd869c489543719ea856d6609cac53cbd4dc122 Reviewed-by: Marc Mutz <marc.mutz@qt.io> Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
Diffstat (limited to 'tests/auto/corelib/time/qdate/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/time/qdate/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/corelib/time/qdate/CMakeLists.txt b/tests/auto/corelib/time/qdate/CMakeLists.txt
index 4dff2a6639..4d0f04a967 100644
--- a/tests/auto/corelib/time/qdate/CMakeLists.txt
+++ b/tests/auto/corelib/time/qdate/CMakeLists.txt
@@ -19,4 +19,5 @@ qt_internal_add_test(tst_qdate
QT_NO_KEYWORDS
LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)