summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2017-05-02 19:23:13 +0200
committerFabian Kosmale <fabian.kosmale@qt.io>2020-03-17 10:01:04 +0100
commit165de1002719175c75df61913d36c2189538a84b (patch)
tree39f3be146633ad2f25b1a55d000edb1475149082 /tests/auto/corelib/tools/CMakeLists.txt
parent7ef382649754c261ca9eb99dd50b67050e748efb (diff)
Introduce helper class QTaggedPointer
Useful for attaching small bits of information in the alignment bits of a naked pointer. For use in the new property system as well as in qtdeclarative (where currently a similar class exists as private API). Change-Id: Idf9b93e714e15129f302e16425dbeda94bcd207b Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/corelib/tools/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/corelib/tools/CMakeLists.txt b/tests/auto/corelib/tools/CMakeLists.txt
index f1967c3664..2a7025f97c 100644
--- a/tests/auto/corelib/tools/CMakeLists.txt
+++ b/tests/auto/corelib/tools/CMakeLists.txt
@@ -34,6 +34,7 @@ add_subdirectory(qringbuffer)
add_subdirectory(qscopedpointer)
add_subdirectory(qscopedvaluerollback)
add_subdirectory(qscopeguard)
+add_subdirectory(qtaggedpointer)
add_subdirectory(qset)
# add_subdirectory(qsharedpointer) # special case not ported
add_subdirectory(qsize)