summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/tools/qfreelist/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-04-27 16:46:30 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2020-04-29 22:48:45 +0200
commit3a34fdf72a4305a314c65603b56e2a0c202ccf97 (patch)
treedf090904a5022c240a415db5792a5604e6fc1153 /tests/auto/corelib/tools/qfreelist/CMakeLists.txt
parent9b51d5f5713c237c244c1bff4d0bd3d0437e1b95 (diff)
Port more tests from tests/auto/corelib/tools to CMake
Also removed add_subdirectory calls for subdirs which no longer exist. Change-Id: I759f408ca812e1721dde495b0e23feffdeeb9c60 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/corelib/tools/qfreelist/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/tools/qfreelist/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/auto/corelib/tools/qfreelist/CMakeLists.txt b/tests/auto/corelib/tools/qfreelist/CMakeLists.txt
new file mode 100644
index 0000000000..3940470240
--- /dev/null
+++ b/tests/auto/corelib/tools/qfreelist/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Generated from qfreelist.pro.
+
+#####################################################################
+## tst_qfreelist Test:
+#####################################################################
+
+qt_add_test(tst_qfreelist
+ SOURCES
+ tst_qfreelist.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_qfreelist CONDITION NOT QT_FEATURE_private_tests
+ SOURCES
+ ${QT_SOURCE_TREE}/src/corelib/tools/qfreelist.cpp
+)