summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 18:12:15 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 10:11:39 +0000
commit8305b6fe3f612e4b78b072e8bbe9d354c4a969bb (patch)
treef69f32a206b10a407c813c41df50162deb666958 /tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
parent0650bafa59d280e20f3025859b558962aee95257 (diff)
Regenerate tests/auto/dbus
Change-Id: I105eb73065e02a4fa508d17f481047b32875f128 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
index fdbe587785..1418f43828 100644
--- a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
@@ -7,13 +7,12 @@
# Can't be called qmyserver since the qdbusabstractadaptor test
# already has a executable target named like that, so use
# a different target name and then rename the binary
-add_qt_executable(qmyserver_qdbusinterface
+add_qt_executable(qmyserver_qdbusinterface # special case
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
SOURCES
../myobject.h
qmyserver.cpp
- LIBRARIES
- Qt::Core
+ PUBLIC_LIBRARIES
Qt::DBus
)