summaryrefslogtreecommitdiffstats
path: root/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-01-31 10:22:33 +0100
committerAlbert Astals Cid <albert.astals.cid@kdab.com>2019-01-31 09:45:38 +0000
commitf80a37dcca2d2ef4d238e248e3fb267e679317fd (patch)
tree9e9ed2e8a73cb996fab7b96979c7884046c752e2 /tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
parent743b3d86734b314df9665a7e64adc387b4506594 (diff)
cmake: Enable qdbusinterface test
Change-Id: Ia25911216790abdf463306cdb2e9aecb7dcd276e Reviewed-by: Mikhail Svetkin <mikhail.svetkin@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt')
-rw-r--r--tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
index 627b29ff42..bbbe1e8633 100644
--- a/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
+++ b/tests/auto/dbus/qdbusinterface/qmyserver/CMakeLists.txt
@@ -4,10 +4,16 @@
## qmyserver Binary:
#####################################################################
-add_qt_executable(qmyserver
+# Can't be called qmyserver since the qdbusabstractadaptor test
+# already has a executable target named like that, so use
+# a different target name and then rename the binary
+add_qt_executable(qmyserver_qdbusinterface
SOURCES
../myobject.h
qmyserver.cpp
LIBRARIES
+ Qt::Core
Qt::DBus
)
+
+set_target_properties(qmyserver_qdbusinterface PROPERTIES OUTPUT_NAME qmyserver)