summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/image/qiconhighdpi/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-08 16:30:21 +0200
committerFrederik Gladhorn <frederik.gladhorn@qt.io>2019-10-23 07:56:08 +0000
commitd784864b58f795349c5bb2b857d4e72efc61dd1e (patch)
treef7647c8d29ef542accdc1be46c9570ef0a4598ba /tests/auto/gui/image/qiconhighdpi/CMakeLists.txt
parentc4b7f79e76e6ee20a0acacf97fed7ab6d89798eb (diff)
cmake: add gui/image tests
Fixes: QTBUG-78223 Change-Id: I9a5c90bb664e3baa4481e6bdaa9a4990e3f68317 Reviewed-by: Qt CMake Build Bot Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/gui/image/qiconhighdpi/CMakeLists.txt')
-rw-r--r--tests/auto/gui/image/qiconhighdpi/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/auto/gui/image/qiconhighdpi/CMakeLists.txt b/tests/auto/gui/image/qiconhighdpi/CMakeLists.txt
new file mode 100644
index 0000000000..a49a4f6411
--- /dev/null
+++ b/tests/auto/gui/image/qiconhighdpi/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from qiconhighdpi.pro.
+
+#####################################################################
+## tst_qicon Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ icons/*)
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qiconhighdpi
+ SOURCES
+ tst_qiconhighdpi.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ TESTDATA ${test_data}
+)
+
+# Resources:
+set(tst_qiconhighdpi_resource_files
+ "icons/misc/button.9.png"
+ "icons/misc/button@2x.9.png"
+ "icons/testtheme/16x16/actions/appointment-new.png"
+ "icons/testtheme/22x22/actions/appointment-new.png"
+ "icons/testtheme/22x22@2/actions/appointment-new.png"
+ "icons/testtheme/index.theme"
+)
+
+add_qt_resource(tst_qiconhighdpi "tst_qiconhighdpi"
+ PREFIX
+ "/"
+ FILES
+ ${tst_qiconhighdpi_resource_files}
+)
+