summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/kernel/qhighdpi/CMakeLists.txt
diff options
context:
space:
mode:
authorMorten Johan Sørvig <morten.sorvig@qt.io>2020-02-04 17:47:23 +0100
committerMorten Johan Sørvig <morten.sorvig@qt.io>2020-10-20 07:26:57 +0200
commitd023da86399b99d365f1e745fb0d9424afc8194b (patch)
tree95e7da87a357997ccc82631003cc39b5a6d20a18 /tests/auto/gui/kernel/qhighdpi/CMakeLists.txt
parentf4a66e5c4c4be97a7511b372930e20f330ea0813 (diff)
Add high-dpi auto test
Use the new screen config feature of the offscreen platform plugin to run tests on virtual screen setup. This has the benefit that we can auto-test the QHighDpiScaling implementation (as well as its usage in QtGui) on any platform with a fixed mock screen setup which does not rely on physical screen configuration. Test the following configurations: - three screens: 96 DPI. (reference) - three screens: 192 DPI - three screens: mixed (high) DPI Change-Id: I2fac889d896cf30ab2a79c306cee22177ad8f4ac Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'tests/auto/gui/kernel/qhighdpi/CMakeLists.txt')
-rw-r--r--tests/auto/gui/kernel/qhighdpi/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/gui/kernel/qhighdpi/CMakeLists.txt b/tests/auto/gui/kernel/qhighdpi/CMakeLists.txt
new file mode 100644
index 0000000000..bdd9a5e17f
--- /dev/null
+++ b/tests/auto/gui/kernel/qhighdpi/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Generated from qhighdpi.pro.
+
+#####################################################################
+## tst_qhighdpi Test:
+#####################################################################
+
+qt_internal_add_test(tst_qhighdpi
+ SOURCES
+ tst_qhighdpi.cpp
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+)