summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/text/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2022-12-21 14:03:12 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2022-12-22 00:48:08 +0100
commitd8e213a9e6b3013f768cbf4d94878cd2a0f7bb79 (patch)
tree768c8173f1ea470c567a28420888505fb9d84694 /tests/auto/gui/text/CMakeLists.txt
parent0f16c76e83f711f6b7b7c4b56ee91ec410cc8038 (diff)
Enable and fix the test for QTextImageHandler
Amends 52ce0c177e80c2d5b70b38d429abb3689b3da51e, which added the test without adding it to the parent directory. Refactor the test code to be data driven, add the image files as external test data files, and adjust the test code to find the files. Use the QTextImageFormat from the document rather than a manually crafted one, as otherwise we don't test a real usecase. This also makes the test more flexible for adding qrc, resources, and file URLs. Task-number: QTBUG-109212 Pick-to: 6.5 6.4 6.2 Change-Id: Id0771037b961d95ec3cadd0cd6467d2448f22884 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Reviewed-by: Santhosh Kumar <santhosh.kumar.selvaraj@qt.io>
Diffstat (limited to 'tests/auto/gui/text/CMakeLists.txt')
-rw-r--r--tests/auto/gui/text/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/gui/text/CMakeLists.txt b/tests/auto/gui/text/CMakeLists.txt
index 856551bf52..43c28ec768 100644
--- a/tests/auto/gui/text/CMakeLists.txt
+++ b/tests/auto/gui/text/CMakeLists.txt
@@ -16,6 +16,7 @@ add_subdirectory(qtextcursor)
add_subdirectory(qtextdocumentfragment)
add_subdirectory(qtextdocumentlayout)
add_subdirectory(qtextformat)
+add_subdirectory(qtextimagehandler)
add_subdirectory(qtextlist)
add_subdirectory(qtextobject)
# add_subdirectory(qtextscriptengine) # disable until system_harfbuzz feature is available # special case