summaryrefslogtreecommitdiffstats
path: root/tests/auto/gui/util/qundostack/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2020-03-10 15:40:56 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2020-03-30 12:36:29 +0200
commit3f73995a03c4b40e2648cb9af5d3e7ca393bf597 (patch)
treef7f9f4c63a5506287de4d44d4f01cdc57e093a27 /tests/auto/gui/util/qundostack/CMakeLists.txt
parentadc1be3c33b4237a13e423c140bcb1c06aeb11d9 (diff)
Move undo framework out of Qt Widgets
- Moves QUndo* classes (except QUndoView) from src/widgets/utils to src/gui/utils - Moves related auto tests from widgets to gui - Replaces QUndoAction with lambdas that do text prefixing [ChangeLog][Undo Framework] QUndo* classes (except QUndoView) were moved from Qt Widgets to Qt GUI. Done-with: volker.hilsheimer@qt.io Fixes: QTBUG-40040 Change-Id: I3bd8d4d32c64f8dee548f62159a1df2126da89d8 Reviewed-by: Lars Knoll <lars.knoll@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'tests/auto/gui/util/qundostack/CMakeLists.txt')
-rw-r--r--tests/auto/gui/util/qundostack/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/gui/util/qundostack/CMakeLists.txt b/tests/auto/gui/util/qundostack/CMakeLists.txt
new file mode 100644
index 0000000000..d6cf36187e
--- /dev/null
+++ b/tests/auto/gui/util/qundostack/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Generated from qundostack.pro.
+
+#####################################################################
+## tst_qundostack Test:
+#####################################################################
+
+add_qt_test(tst_qundostack
+ SOURCES
+ tst_qundostack.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)