summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Schmertmann <Lars.Schmertmann@governikus.de>2022-06-13 08:55:07 +0200
committerMÃ¥rten Nordheim <marten.nordheim@qt.io>2022-06-27 14:02:47 +0200
commite3ea1d02e6a2cbc63e8ae6fff6ccae49258fe5a2 (patch)
treea25aaa2ecd63be13ce6e465b67e8a7c88548cfcd /tests/auto/network/access/CMakeLists.txt
parente8a782fb2c4084cd88778e263cef5e323505e145 (diff)
QHttpHeaderParser: Allow larger fields but restrict total size
Our limit of 8k for a single header field was too small for certain services which returned Location values or WWW-Authenticate challenges longer than 8k. Instead, taking inspiration from Chromium, we have a limit of 250k for the full header itself. And increasing our field limit to 100k, which would occupy almost half of what the total header allows. Also took the opportunity to make it adjustable from the outside so we can set more strict limits in other components. Fixes: QTBUG-104132 Pick-to: 6.3 6.4 Change-Id: Ibbe139445e79baaef30829cfbc9a59f884e96293 Reviewed-by: Ievgenii Meshcheriakov <ievgenii.meshcheriakov@qt.io>
Diffstat (limited to 'tests/auto/network/access/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/network/access/CMakeLists.txt b/tests/auto/network/access/CMakeLists.txt
index d225eb1299..3292bb1471 100644
--- a/tests/auto/network/access/CMakeLists.txt
+++ b/tests/auto/network/access/CMakeLists.txt
@@ -9,6 +9,7 @@ add_subdirectory(qnetworkreply)
add_subdirectory(qnetworkcachemetadata)
add_subdirectory(qabstractnetworkcache)
if(QT_FEATURE_private_tests)
+ add_subdirectory(qhttpheaderparser)
add_subdirectory(qhttpnetworkconnection)
add_subdirectory(qhttpnetworkreply)
add_subdirectory(hpack)