summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qftp/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-08-20 12:03:54 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-08-27 18:58:21 +0200
commitf7f79483e73fed5664763a125b3d27861586b7d2 (patch)
tree13910131de10d3d8d6d240b4cfd05309de8343c8 /tests/auto/network/access/qftp/CMakeLists.txt
parent3964ece5a566d1ed517406f0ff713f6f184628ae (diff)
Remove QFtp sources etc. in favor of alternate distribution
While we initially wanted to just disable the functionality the way it is currently built forces people to do a full build of Qt just to enable it. Instead of doing this half-measure let's just remove the code completely from QtBase and rather prepare QtNetwork to handle being a plugin that can be compiled at any time. Task-number: QTBUG-80340 Change-Id: I19155c8c167cf932088f01b2a9706d0e7ab792d1 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'tests/auto/network/access/qftp/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qftp/CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/tests/auto/network/access/qftp/CMakeLists.txt b/tests/auto/network/access/qftp/CMakeLists.txt
deleted file mode 100644
index f67ddd3326..0000000000
--- a/tests/auto/network/access/qftp/CMakeLists.txt
+++ /dev/null
@@ -1,25 +0,0 @@
-# Generated from qftp.pro.
-
-if(NOT QT_FEATURE_ftp)
- return()
-endif()
-if(NOT QT_FEATURE_private_tests)
- return()
-endif()
-
-#####################################################################
-## tst_qftp Test:
-#####################################################################
-
-qt_add_test(tst_qftp
- SOURCES
- tst_qftp.cpp
- PUBLIC_LIBRARIES
- Qt::Network
- Qt::NetworkPrivate
-)
-
-#### Keys ignored in scope 1:.:.:qftp.pro:<TRUE>:
-# QT_FOR_CONFIG = "network"
-# QT_TEST_SERVER_LIST = "vsftpd" "ftp-proxy" "squid" "danted"
-# _REQUIREMENTS = "qtConfig(ftp)" "qtConfig(private_tests)"