summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2019-07-24 13:03:33 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-07-29 13:14:55 +0000
commit6887ae2ff9f66bc30161d6234ca7afa93a5d4b22 (patch)
tree7a4340ffd2f77e2a503b48bc3e27b1e2c8461363 /tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
parent1307736c7db1ff24e3b8282f4a7b14d24866feba (diff)
cmake: Enable network test
Task-number: QTBUG-74146 Change-Id: Ib29d1531f89676afb2b4df5032529b731ace029d Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/network/access/qnetworkreply/test/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qnetworkreply/test/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
new file mode 100644
index 0000000000..df589b67da
--- /dev/null
+++ b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from test.pro.
+
+#####################################################################
+## tst_qnetworkreply Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "../empty")
+list(APPEND test_data "../rfc3252.txt")
+list(APPEND test_data "../resource")
+list(APPEND test_data "../bigfile")
+
+file(GLOB test_data_glob
+ LIST_DIRECTORIES true
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ "../*.jpg")
+list(APPEND test_data ${test_data_glob})
+list(APPEND test_data "../certs")
+list(APPEND test_data "../index.html")
+list(APPEND test_data "../smb-file.txt")
+
+add_qt_test(tst_qnetworkreply
+ GUI
+ SOURCES
+ ../../../../../shared/emulationdetector.h
+ ../tst_qnetworkreply.cpp
+ INCLUDE_DIRECTORIES
+ ../../../../../shared
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::NetworkPrivate
+ PUBLIC_LIBRARIES
+ Qt::Network
+ TESTDATA ${test_data}
+)
+
+# Resources:
+add_qt_resource(tst_qnetworkreply "qnetworkreply"
+ BASE
+ ".."
+ FILES
+ resource
+)
+
+
+#### Keys ignored in scope 1:.:.:test.pro:<TRUE>:
+# CONFIG = "testcase" "-debug_and_release_target" "unsupported/testserver"
+# QT_FOR_CONFIG = "gui-private"
+# QT_TEST_SERVER_LIST = "vsftpd" "apache2" "ftp-proxy" "danted" "squid"
+# testcase.timeout = "600"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# TEST_HELPER_INSTALLS = "../echo/echo"