summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-05-13 11:04:28 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2021-06-12 00:04:04 +0200
commit6f25051536c1636688a0a0939196007aac34676d (patch)
tree390fc3fc4e0147a51d56aee6d563614b77981b6a /tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
parentf9b867216ba2728ff993020599f5062e2f023de1 (diff)
QNetworkReply: Decompress when reading
Rather than when the data is received. Source compatibility is achieved through double-decompressing the data. This lets us know how many bytes are available just as before but without having the uncompressed data left in memory. Fixes: QTBUG-83269 Change-Id: I352bd09581614c582e4628243e2a0e895ba4946b Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
Diffstat (limited to 'tests/auto/network/access/qnetworkreply/test/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qnetworkreply/test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
index 17ce3c5c16..d54fb40c56 100644
--- a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
+++ b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
@@ -21,6 +21,8 @@ qt_internal_add_test(tst_qnetworkreply
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../" # special case
SOURCES
../tst_qnetworkreply.cpp
+ ../data/gzip.rcc.cpp
+ ../data/zstandard.rcc.cpp
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::NetworkPrivate