summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2023-06-12 14:25:27 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2023-06-21 01:04:04 +0300
commitf667445006c52f26103540ae18964a0015a297db (patch)
tree726be23d57ff98725432d89e586e6dd24bffdb49 /tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
parent9d5a8162a5a168972c7aaf39b130da6a72dc13e2 (diff)
Android: explicitly bundle the OpenSSL libs for tests
Use the new argument to bundle the OpenSSL prebuilt libararies so that ssl operations are actually tested at runtime. Task-number: QTBUG-110025 Pick-to: 6.6 6.5 Change-Id: I0d73fed463a1724a9e0ee84ba603aa2ff1bc649b Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'tests/auto/network/access/qnetworkreply/test/CMakeLists.txt')
-rw-r--r--tests/auto/network/access/qnetworkreply/test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
index 583b250932..fa353b2769 100644
--- a/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
+++ b/tests/auto/network/access/qnetworkreply/test/CMakeLists.txt
@@ -29,6 +29,7 @@ qt_internal_add_test(tst_qnetworkreply
Qt::NetworkPrivate
TESTDATA ${test_data}
QT_TEST_SERVER_LIST "vsftpd" "apache2" "ftp-proxy" "danted" "squid"
+ BUNDLE_ANDROID_OPENSSL_LIBS
)
add_dependencies(tst_qnetworkreply echo)