summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amir.abdol@qt.io>2023-03-01 15:41:14 +0100
committerThiago Macieira <thiago.macieira@intel.com>2023-05-11 17:05:25 -0700
commit68b625901f9eb7c34e3d7aa302e1c0a454d3190b (patch)
tree36faae7f3c3b7d573a82e08390c7f8c03900408e /tests/auto/network/kernel/CMakeLists.txt
parentff9da1db0b0963f967f45ab430ec40a3051b70b4 (diff)
Network: link directly to libresolv instead of dlopen()ing it
There's little need for us to dynamically load it. The reasons why that was necessary aren't in the public history (Qt 4.5 already had it[1]). I remember writing the code in 2007-2008, I just don't remember why. On modern Linux and FreeBSD, there's no libresolv.so any more and those symbols have been rolled up into libc.so. It's still necessary on Darwin systems, so this commit introduces WrapResolv. It also resolves the unity build issues relating to libresolv symbols. [1] https://code.qt.io/cgit/qt/qt.git/tree/src/network/kernel/qhostinfo_unix.cpp?h=v4.5.1 Task-number: QTBUG-109394 Change-Id: Ic5799e4d000b6c9395109e008780643bac52122b Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'tests/auto/network/kernel/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/network/kernel/CMakeLists.txt b/tests/auto/network/kernel/CMakeLists.txt
index 2f5f935f29..f5760c9b0b 100644
--- a/tests/auto/network/kernel/CMakeLists.txt
+++ b/tests/auto/network/kernel/CMakeLists.txt
@@ -1,7 +1,7 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-if(NOT INTEGRITY)
+if(WIN32 OR TEST_res_ninit)
add_subdirectory(qdnslookup)
add_subdirectory(qdnslookup_appless)
endif()