summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2021-04-13 17:01:38 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2021-04-14 10:47:20 +0200
commite875c071ec32ab9aa460c982f25f6c6191e41326 (patch)
tree4c2a3e4bf9a301f0a906a0f74ae230b78093b294 /tests/auto/network/kernel/CMakeLists.txt
parentd61dc9a8cda2e3f3c3eb91283af71e9cd5044fd8 (diff)
QNetworkInformation: delete the instance as a post-routine
On Windows, on exit, the backend will deref (and then implicitly start deletion of) a COM object. This object tries to communicate with an object in another thread, though it seems this other thread quits before the main thread in _most_ cases. To get around this we move the deletion to earlier in the program. While this is only reported as a Windows issue it makes for more consistent behavior if all platforms behave the same. Document and test that recreation of QNI works as expected after the destruction (and recreation) of QCoreApplication. Amends: 0875626e22ad4e709ddf505e701a8d699559f5b4 Fixes: QTBUG-92568 Pick-to: 6.1 6.1.0 Change-Id: Iffc07f38673019aa059efd4d64d2ad706a03f6fe Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io> Reviewed-by: Oliver Wolff <oliver.wolff@qt.io>
Diffstat (limited to 'tests/auto/network/kernel/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/network/kernel/CMakeLists.txt b/tests/auto/network/kernel/CMakeLists.txt
index 89526fa14c..11b859011e 100644
--- a/tests/auto/network/kernel/CMakeLists.txt
+++ b/tests/auto/network/kernel/CMakeLists.txt
@@ -14,4 +14,5 @@ endif()
if(QT_FEATURE_private_tests)
add_subdirectory(qauthenticator)
add_subdirectory(qnetworkinformation)
+ add_subdirectory(qnetworkinformation_appless)
endif()