summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/kernel/qdnslookup/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2023-08-28 14:34:44 +0200
committerIvan Solovev <ivan.solovev@qt.io>2023-09-03 18:20:56 +0200
commit96a62cd1f5e5c5a915d60ba6d86a5ea44fc32acc (patch)
tree77522f17890194d8ab8a12ab5605aa9d35605d08 /tests/auto/network/kernel/qdnslookup/CMakeLists.txt
parentac59fcdab8adb80648fee15956428630946dd01d (diff)
tst_QDnsLookup: extend test coverage for property bindings
The pre-existing tests were not using the QTestPrivate helpers, so extend them with the call to QTestPrivate::testReadWritePropertyBasics. The updated test didn't reveal any problems with binding loops, so no other action is required for now. Task-number: QTBUG-116346 Pick-to: 6.6 6.5 Change-Id: I51a17974a7f5bec3c969fcb55b6f28e3e9218eb5 Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'tests/auto/network/kernel/qdnslookup/CMakeLists.txt')
-rw-r--r--tests/auto/network/kernel/qdnslookup/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/network/kernel/qdnslookup/CMakeLists.txt b/tests/auto/network/kernel/qdnslookup/CMakeLists.txt
index 74ace2b174..ea539ecbe0 100644
--- a/tests/auto/network/kernel/qdnslookup/CMakeLists.txt
+++ b/tests/auto/network/kernel/qdnslookup/CMakeLists.txt
@@ -16,6 +16,7 @@ qt_internal_add_test(tst_qdnslookup
tst_qdnslookup.cpp
LIBRARIES
Qt::Network
+ Qt::TestPrivate
)
qt_internal_extend_target(tst_qdnslookup CONDITION WIN32