summaryrefslogtreecommitdiffstats
path: root/tests/auto/network/socket/platformsocketengine/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-07-10 21:18:53 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-07-12 18:56:14 +0200
commit72a90810cb8e418c5317f484c5b2f9bb8cf264a0 (patch)
tree2d0ff15eeb3a204e3f2e416f7e3d1503c6a5b376 /tests/auto/network/socket/platformsocketengine/CMakeLists.txt
parent3ab4742c006a02d7650aeda0ad359c3231ab477d (diff)
CMake: Remove the usage of QT_SOURCE_TREE from tests
The ${QT_SOURCE_TREE}/src/network include paths of several tests are apparently not needed anymore. Remove those. tst_qfilesystementry and tst_qfreelist are the only tests that actually need to reference files in qtbase's source tree. Simply use the paths relative to the project file. Task-number: QTBUG-88090 Change-Id: Ic6f341e001338c1b07dce6e58316245bc9560c5e Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/network/socket/platformsocketengine/CMakeLists.txt')
-rw-r--r--tests/auto/network/socket/platformsocketengine/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/auto/network/socket/platformsocketengine/CMakeLists.txt b/tests/auto/network/socket/platformsocketengine/CMakeLists.txt
index 21bc3e2c80..cfd8a118ca 100644
--- a/tests/auto/network/socket/platformsocketengine/CMakeLists.txt
+++ b/tests/auto/network/socket/platformsocketengine/CMakeLists.txt
@@ -11,8 +11,6 @@ endif()
qt_internal_add_test(tst_platformsocketengine
SOURCES
tst_platformsocketengine.cpp
- INCLUDE_DIRECTORIES
- ${QT_SOURCE_TREE}/src/network
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::NetworkPrivate