summaryrefslogtreecommitdiffstats
path: root/tests/auto/other/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-08-18 10:25:05 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-08-23 16:21:57 +0200
commit2e340cea88b6721cf09f24a190aa6a81af81852e (patch)
tree89f83984eb2f3521ba038300ed88fa18c24ded6f /tests/auto/other/CMakeLists.txt
parentaff0915352dda0cfaa11a249b665fbe47be21d69 (diff)
Add test for the qt6_android_generate_deployment_settings CMake command
qt6_android_generate_deployment_settings is implicitly used by qt6_add_executable in user projects. This test makes sure that the function behaves as expected for user projects specificly, since in Qt tests it behaves differently because of Qt-specific conditions inside. Task-number: QTBUG-116037 Pick-to: 6.6 Change-Id: Iea10eca7a780ebaff0c05b91ebe47b821b9ec956 Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/other/CMakeLists.txt')
-rw-r--r--tests/auto/other/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/other/CMakeLists.txt b/tests/auto/other/CMakeLists.txt
index 0964cce7aa..5e2be543b5 100644
--- a/tests/auto/other/CMakeLists.txt
+++ b/tests/auto/other/CMakeLists.txt
@@ -46,3 +46,7 @@ endif()
if(QT_FEATURE_xkbcommon AND TARGET Qt::Gui)
add_subdirectory(xkbkeyboard)
endif()
+
+if(ANDROID)
+ add_subdirectory(android_deployment_settings)
+endif()