summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-08-01 19:36:03 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-08-07 11:55:38 +0000
commite76c83a879f4a2efa40ee5e65acebefc8f9b4cb1 (patch)
tree187746a8a1b754d9dccbc249b45d2df4d851df0d /tests/auto/testlib/CMakeLists.txt
parentb4ef975a0a6e8c22d3c0851f9d7b11738d37b662 (diff)
Regenerate some of the test projects that do SUBDIRS += foo
This show cases the new cleaner subdirs handling code in pro2cmake. Change-Id: I25001942ef020e4c4191b355f55309c4fb033ecc Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/testlib/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/auto/testlib/CMakeLists.txt b/tests/auto/testlib/CMakeLists.txt
index a87e2203f9..fe80927327 100644
--- a/tests/auto/testlib/CMakeLists.txt
+++ b/tests/auto/testlib/CMakeLists.txt
@@ -1,4 +1,8 @@
-add_subdirectory(qabstractitemmodeltester)
+# Generated from testlib.pro.
+
+# add_subdirectory(outformat) # special case missing project
add_subdirectory(qsignalspy)
add_subdirectory(selftests)
-
+if(TARGET Qt::Widgets)
+ add_subdirectory(qabstractitemmodeltester)
+endif()