summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 11:02:59 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 13:36:00 +0000
commit71c43b035b24269a36d09ef77b1f3f139406fbfc (patch)
tree7480721394c0cb0a5bfa60653ba505098665ae29 /tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt
parent3919ed58abdd80ac7f964c91bead7bd8d4543079 (diff)
Regenerate tests/auto/testlib
Change-Id: If1b2e105836b73b1a68ed5a8e11feb8e114d66e2 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt b/tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt
index bcb975d846..c4c9b7d044 100644
--- a/tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt
+++ b/tests/auto/testlib/qabstractitemmodeltester/CMakeLists.txt
@@ -1,8 +1,16 @@
-add_qt_test(tst_qabstractitemmodeltester SOURCES
+# Generated from qabstractitemmodeltester.pro.
+
+#####################################################################
+## qabstractitemmodeltester Test:
+#####################################################################
+
+add_qt_test(qabstractitemmodeltester
+ SOURCES
+ ../../other/qabstractitemmodelutils/dynamictreemodel.cpp ../../other/qabstractitemmodelutils/dynamictreemodel.h
tst_qabstractitemmodeltester.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../../other/qabstractitemmodelutils/dynamictreemodel.cpp
INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_SOURCE_DIR}/../../other/qabstractitemmodelutils
- LIBRARIES
+ ../../other/qabstractitemmodelutils
+ PUBLIC_LIBRARIES
+ Qt::Gui
Qt::Widgets
)