summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-07-28 00:03:00 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-07-29 15:39:40 +0200
commitedba9cddbb7f2e68436ee256d4471909e33d288f (patch)
treed09ba78d3e995fcbe99c17c54c4082809bb45a8e /tests/auto/testlib/selftests/CMakeLists.txt
parent08a1bcfa9b6672d0b71f5b3de0d6c58a8f549ea1 (diff)
testlib: Accurately name JUnit test, and only run for JUnitXML reporter
The JUnit reporter was initially named xunit, but the naming was inaccurate and the reporter was renamed in 27db9e458cef512fca3a6b5c9ebbcda7a8172428. The corresponding test has now been renamed as well, and as an added bonus we only run it for that reporter. Pick-to: 6.2 Change-Id: I59cb7d949514cdf46a0199a53a7a3e39f833207c Reviewed-by: Mårten Nordheim <marten.nordheim@qt.io> Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'tests/auto/testlib/selftests/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/testlib/selftests/CMakeLists.txt b/tests/auto/testlib/selftests/CMakeLists.txt
index 3a2def6de2..0564fdaaf7 100644
--- a/tests/auto/testlib/selftests/CMakeLists.txt
+++ b/tests/auto/testlib/selftests/CMakeLists.txt
@@ -91,6 +91,7 @@ set(subprograms
findtestdata
float
globaldata
+ junit
longstring
maxwarnings
multiexec
@@ -116,7 +117,6 @@ set(subprograms
verifyexceptionthrown
warnings
watchdog
- xunit
)
if(TARGET Qt::Gui)