summaryrefslogtreecommitdiffstats
path: root/tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2023-08-26 17:16:27 -0700
committerThiago Macieira <thiago.macieira@intel.com>2023-09-06 12:36:06 -0700
commitb6462bbd5c1708d7743c99a56f2d90026a801e2f (patch)
tree18b46a1989759f081e0d9d91a4ede9e5f0526c6e /tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt
parent1c8402dd412e64216d42bfa6c15e8f3d58081a81 (diff)
tst_selftests: split the qFatal() test away from tst_Silent
This allows us to control whether to run this particular test in ASan mode or with specific loggers or not. Adding the expected log output for tst_silent for other loggers is left as an exercise to the reader. Change-Id: Ifa1111900d6945ea8e05fffd177f1548c8c8e714 Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io> Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
Diffstat (limited to 'tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt')
-rw-r--r--tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt b/tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt
new file mode 100644
index 0000000000..f19ffb4ff6
--- /dev/null
+++ b/tests/auto/testlib/selftests/silent_fatal/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_executable(silent_fatal
+ NO_INSTALL
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ SOURCES
+ tst_silent_fatal.cpp
+ LIBRARIES
+ Qt::TestPrivate
+)
+
+# No coverage because this crashes, making data collection difficult, if not
+# impossible.