summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-06-25 15:48:48 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-26 22:14:09 +0200
commit167741717ffd7e82cd127b1671b990cd03a8096c (patch)
tree0a2c95fa8532f89b2f9b6cf9dfa0e4be266a09fd /tests/auto/tools/CMakeLists.txt
parenta2c772dc58162329a46918950f85e55339939499 (diff)
CMake: Fix tst_qmake not to hang and re-enable it
We don't really know why, but using the ctest --force-new-ctest-process flag stops the test from hanging. Also re-enable the test. Task-number: QTBUG-78449 Task-number: QTBUG-81365 Change-Id: I33094696dfe3f610dc257089074b1c2a9926f651 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
index 048051663d..b0895a1e70 100644
--- a/tests/auto/tools/CMakeLists.txt
+++ b/tests/auto/tools/CMakeLists.txt
@@ -1,11 +1,7 @@
# Generated from tools.pro.
add_subdirectory(qmakelib)
-# special case begin
-if(NOT WIN32) # @todo: this is broken, see QTBUG-78449
- add_subdirectory(qmake)
-endif()
-# special case end
+add_subdirectory(qmake)
#add_subdirectory(moc)
add_subdirectory(rcc)
if(TARGET Qt::Widgets)