summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2020-04-27 16:25:20 +0200
committerFabian Kosmale <fabian.kosmale@qt.io>2020-08-10 12:59:46 +0200
commit7b3a2f5e3d5f496036c4ea7e2fa3778fce848e57 (patch)
treeed8df3e6e738297df79877381489897334cd3c35 /tests/auto/tools/CMakeLists.txt
parent3e09c28101d1af1dd90a4b515d7edbe5a3737f97 (diff)
cmake support for tst_moc
We use qt_wrap_cpp instead of AUTOMOC so that we can easily find the json files. Getting autorcc to run only after json file has been generated was deemed too tricky. Therefore the test is slightly modified to check for the json files in its directory instead of the resource, if the qrc file does not exist. Change-Id: Id1aabb117c8bab3ff81156da1f66d64e796bf18b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
index 128b919538..d6cc753db7 100644
--- a/tests/auto/tools/CMakeLists.txt
+++ b/tests/auto/tools/CMakeLists.txt
@@ -2,7 +2,7 @@
add_subdirectory(qmakelib)
add_subdirectory(qmake)
-#add_subdirectory(moc) # special case to be ported
+add_subdirectory(moc)
add_subdirectory(rcc)
if(TARGET Qt::Widgets)
add_subdirectory(uic)