summaryrefslogtreecommitdiffstats
path: root/tests/auto/wasm/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Wierciński <piotr.wiercinski@qt.io>2023-12-06 16:41:11 +0100
committerPiotr Wierciński <piotr.wiercinski@qt.io>2024-02-07 13:15:09 +0100
commitd2862a8f026bcce5a31aff08adc98013f8becf3f (patch)
tree9566c54b5bd3dbd154626fbca784a40ec3618b65 /tests/auto/wasm/CMakeLists.txt
parenta046bc19e451f6f2e42ac1fcddaf5ef3efc81f0d (diff)
wasm: Refractor Selenium manual test into auto test
Using Selenium for WebAssembly testing enables us to test user interactions, which is very valuable. Turning this test into automated allows us to run it in CI pipeline. This will help with detecting regressions. Two of these tests are currently failing on CI machine and they have been temporarily disabled. Change-Id: I754dd05955e55eb031070f5328ef715b7826c2b5 Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'tests/auto/wasm/CMakeLists.txt')
-rw-r--r--tests/auto/wasm/CMakeLists.txt65
1 files changed, 2 insertions, 63 deletions
diff --git a/tests/auto/wasm/CMakeLists.txt b/tests/auto/wasm/CMakeLists.txt
index 5036678bf6..ee60817410 100644
--- a/tests/auto/wasm/CMakeLists.txt
+++ b/tests/auto/wasm/CMakeLists.txt
@@ -5,66 +5,5 @@
## tst_wasm Test:
#####################################################################
-if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
- cmake_minimum_required(VERSION 3.16)
- project(tst_localfileapi LANGUAGES CXX)
- find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
-endif()
-
-qt_internal_add_test(tst_fetchapi
- SOURCES
- tst_fetchapi.cpp
- DEFINES
- QT_NO_FOREACH
- LIBRARIES
- Qt::GuiPrivate
- Qt::Network
- PUBLIC_LIBRARIES
- Qt::Core
-)
-
-qt_internal_add_test(tst_localfileapi
- SOURCES
- tst_localfileapi.cpp
- DEFINES
- QT_NO_FOREACH
- LIBRARIES
- Qt::GuiPrivate
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-qt_internal_add_test(tst_qwasmwindowstack
- SOURCES
- tst_qwasmwindowstack.cpp
- DEFINES
- QT_NO_FOREACH
- LIBRARIES
- Qt::GuiPrivate
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-qt_internal_add_test(tst_qwasmwindowtreenode
- SOURCES
- tst_qwasmwindowtreenode.cpp
- DEFINES
- QT_NO_FOREACH
- LIBRARIES
- Qt::GuiPrivate
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-qt_internal_add_test(tst_qwasmkeytranslator
- SOURCES
- tst_qwasmkeytranslator.cpp
- DEFINES
- QT_NO_FOREACH
- LIBRARIES
- Qt::GuiPrivate
- Qt::Core
-)
+add_subdirectory(misc)
+add_subdirectory(selenium)